return to Table of Contents, Integrations, Managing Mailing Lists

Importing addresses from FileMaker Pro

Direct Mail can import data from FileMaker Pro databases. You must have FileMaker Pro or FileMaker Pro Advanced installed and running for this feature.

Special Instructions for FileMaker Pro 16 and Newer

FileMaker Pro 16 includes new security features that, by default, prevent it from talking to any third-party applications. You will need to adjust your FileMaker security settings to allow it to talk to Direct Mail. If you are using a version of FileMaker that is older than version 16, you can skip these security-related instructions.

  1. Open FileMaker Pro
  2. Choose File > Manage > Security from the menu bar at the top of your screenfmp-manage-security.png
  3. Select your user account on the left (e.g. Admin), then locate the "Privilege Set" settings and click Editfmp-edit-privs.png
  4. In the Extended Privileges section, scroll down and check the box labeled "Allow Apple events and ActiveX to perform FileMaker operations"fmp-ext-priv.png
  5. Click OK until you have exited the security settings dialog

After adjusting your security settings, please follow these instructions to import addresses from FileMaker Pro:

Instructions for All Versions of FileMaker Pro

  1. Choose Addresses > Import
  2. Choose "FileMaker Pro" from the popup menu. If FileMaker Pro is not open, it will be opened in the background.
  3. Direct Mail will display the fields from the database and layout that is currently selected in FileMaker Pro. If you want to use different fields, switch into FileMaker Pro, make your selection, then switch back to Direct Mail.
  4. Choose how you would like each field imported by selecting from the popup menus in the Import As column. import-csv-columns.png
  5. Click Import

After you click Import, FileMaker Pro may be unresponsive until the import completes.

Troubleshooting

If Direct Mail reports that it is unable to connect to FileMaker, here are some things to check:

  • FileMaker Pro is open and running
  • There are no dialogs or alerts blocking the screen in FileMaker
  • You have a database open in FileMaker
  • The layout you have selected in FileMaker has at least one field. You can add fields to your layout in FileMaker by choosing View > Layout Mode from the menu bar and then choosing Insert > Field from the menu bar.
  • Make sure you have followed the security-related instructions at the top of this help article

Did you find this article helpful? Yes | No